Posts tagged ‘nvidia’

Farewell GTX, Hello GTX

Saturday night I sat down at my gaming desktop to check in on some MMOs that I hadn’t logged into in months, namely LotRO, Rift, and Defiance.

I spent about 15 minutes in Rift moving all my inventory over to my Vault and then redeeming all of the patronage rewards that had been stacking up before canceling my subscription. I haven’t touched the game since before it went free-to-play, it’s just too much work to get back up to speed with all of the soul changes, and had been waiting on my last renewal to run out.

Then I hopped into LotRO just intending to pay my housing upkeep, but I ended up fiddling around and discovered that the inventory system changed. I was able to merge all my individual bags into a single window! Maybe I’m easily amused, but it makes thing so much easier when only one large window pops open instead of six little windows. I imagine people running mods have been enjoying something similar for a while, but I really dislike messing with mods for MMO clients.

Anyway, I ended up playing with my Hunter a bit and figuring out the big class changes from a few months back. I had just finished and ported back to where I’d left off questing when the game crashed. I chalked it up to LotRO being old, after all it is still slow to load and still doesn’t support full-screen windowed mode, and decided to move on to Defiance.

Watching the Season 2 premiere got me curious about what state the game was in. When I logged in, I found that I had more than a dozen items to claim in the shop. Once I got my inventory squared away, I got on my ATV and headed out only to have the game crash. Again, not thinking anything of it, I relaunched and noticed a button to update appearance on the login screen, and decided to have a makeover. While tweaking my character’s appearance I had the screen go black and then a Windows message popped up that my graphics kernel has crashed and restarted.

I had recently update my drivers and wondered if that had been a mistake, but went ahead and went back to fiddling with my character’s appearance. Then red lines started to appear on the screen, followed by my machine rebooting.

Crap.

When my machine came back up in safe mode and there were still red lines on the screen, I knew it wasn’t the drivers. Or at least wasn’t only the drivers.

I’ve never had a video card die on me before, especially one that’s only a coupe of years old. I’m not sure when but sometime in the last five years I’d upgrades the original GTX 275 that I’d used in the build with a GTX 580, so it’s no older than that. It has seen pretty constant use though.

Regardless, I took a trip to Fry’s on Sunday and picked up a new GTX 760, which isn’t quite top of the line, but is still better than the 580 without being ludicrously expensive. Plus my motherboard is old enough to be PCI-express 2.0 not 3.0 so I’m already capping my performance with the 760 as it is.

Nvidia 196.75 Drivers Recalled

The More You KnowPicked up on this via Stropp (who got it from Engadget). If you are using the latest Nvidia drivers, 196.75, you’ll want to roll them back. Apparently there’s a problem related to the fan controllers which can cause the card to overheat and possibly kill your GPU.

I looked at Nvidia’s support site, and you can’t even download the 75’s now. The current driver release for the 200 series cards for Windows 7 64-bit is 196.21, which is what I’ve been using since the end of January with no problems.

Nvidia Stutter is Gone

So back in October, I mentioned a problem I was having with my GeForce GTX 275 in Champions Online after updating to the (then) current drivers of 191.07 from 190.62. Since then I have kept an occasional eye on the Champions forums and gone to the Nvidia site once or twice to see if there were new drivers, but I’ve stayed at 190.62. At least until I caught this twitter status from Daeke. Even though I wasn’t having problems with the 190.62 version, I do like to stay up-to-date, and I’d had no problems rolling back the drivers before. So….

I downloaded the new 196.21 drivers, which were released on the 19th, and did an install. I haven’t had a chance to play Star Trek Online’s beta with them yet, but I did get into Champions Online and did some very informal testing (I’m a developer after all, not QA). So far, I’ve noticed none of the stuttering I’d been having with the old drivers and performance seemed just as good for me as always. We’ll see how it holds up this weekend when I get a chance to play more.

Windows 7 Upgraded

I got my copy of Windows 7 Home Premium (full install license) from Amazon on release day, via pre-order.  I wasn’t in a big hurry to upgrade since I’m already running the release candidate, which worked well since the last week has been pretty busy with family stuff (vacation, son’s first birthday).  Even though I wasn’t in a huge hurry, I didn’t want to wait too long, so when my evening freed up last night I decided it was time.  I didn’t technically upgrade, since I was already using the release candidate.

To start the process, I made a backup of my AppData and other user folders, then repartitioned and reformatted the drive.  The complete installation time from booting the PC with the DVD in the drive until the desktop came up was 25 minutes.  That of course was the easy part.  The next step was about 160 MB of downloads from Windows Update for security patches and driver updates for my keyboard, mouse, monitor, and graphics card.  This took about 20 minutes and required a reboot.

The only problem I had with Windows Update was the Nvidia drivers it installed.  It used the 191.07 Nvidia drivers which I found caused a stutter problem in Champions Online, but I was able to install the 190.62 drivers over the top of the existing 191.07 without any problems.

Installing software and games took another 5 hours, but I’m now back up and running on the Home Premium retail version.  I did backup my MMO program folders.  Instead of restoring them, I did re-run the installers but then I brought over the patched files before running the patcher.  This way I get the icons in the Games folder setup correctly but didn’t have to sit through hours of patch downloads.

The only major pain I had was fixing the 30 odd podcasts subscriptions I had in my Zune software.  There really should be a way to export those subscriptions as an XML to make it easier to move machines.

Since I was already on the release candidate, the upgrade really didn’t change much for me, but I’m still really enjoying the UI changes from XP to 7.  It may not be worth upgrading an existing machine, but if you’re building or buying a new box 7’s definitely the way to go.

On the 32- or 64-bit question, I recommend 64-bit.  You may have some compatibility issues on old peripherals, but most components should be fine and I’ve not had any software issues except for UAC.

Nvidia Stutter

I recently updated the drivers for my Geforce GTX 275 from 190.62 to 191.07.  I was not having any performance problems.  I just updated because they were there.  Unfortunately there’s a problem with the 191.07 drivers and Champions Online.  Before the update, I was getting 45-50 FPS with all the settings maxed out.  After the update, I was seeing stutters where the FPS would drop to 10-12 for a few seconds at a time.  A few times the stuttering completely went away and a few times it was severe enough that I logged out of the game, but mostly it was just an annoyance.

After doing a few Google searches and checking the Champion forums, I decided to re-install the 190.62 drivers and hope that whatever was causing the problem rolled-back correctly.  I’ve been churning drivers so much recently with my new machine, that I even had the driver installation file still in my downloads folder.  There are a lot of detailed directions on the forums that include things like rebooting in safe mode and cleaner scans, but I didn’t do anything nearly so complicated.  All I did was rerun the 190.62 installation file and then go to the Nvidia control panel to verify the version number.  No reboot, no registry scan, and no uninstall of current drivers.  I’ve done a short play session in the same area of Canada where I was seeing fairly consistent stutters, and the problem appears gone.

So going forward, I’ll be holding off on any more driver updates, unless I find that I need them.